DevToys 개발자 헬퍼툴, 뭘로 만들어졌나 살펴봤습니다.

DevToys-app/DevToys: A Swiss Army knife for developers. (github.com)

UI코드는 모든 플랫폼에서 웹뷰를 띄우고 블레이저를 사용하고 있습니다.

그 껍데기로는 windows에서는 wpf,
리눅스는 Gtk 라는걸 사용하는 것으로 보이고,
맥 버전은 맥OS에서 rider로 소스를 켜도 오류로 확인이 어렵네요.

NSApplication 이라는게 특정 프레임워크에 종속된 건지… 어떤걸 설치해야 확인할수 있는지 잘 모르겟습니다.

NETSDK1135 SupprtedOSPlatformVersion12.0은 TargetPlatformVersion 0.0 보다 높을 수 없습니다. 라는 에러가 나오고있는데, 마우이에 종속된 건가 싶어서 Maui설치해봐도 안되네요

3 Likes

NSApplication 는 아마 xcode쪽 말하는거 같네요. 맥 개발쪽입니다.
AppKit 활성화가 되어 있어야 합니다. 빌드 할려면요

1 Like